Forums

LAST FORUM POSTS
goto PostRE: 1967 Selectamati...(13)
 by John_Allen
 on 30. Jul at 12
goto PostRE: Photos from Bilo...(1)
 by tomwill
 on 30. Jul at 12
goto PostRE: Cropmaster P25(16)
 by razzledog
 on 30. Jul at 12
goto PostPhotos from Biloela ...(1)
 by ianoz
 on 30. Jul at 12
goto PostRE: 1967 Selectamati...(13)
 by mayneisland880
 on 30. Jul at 12

[Access Forum]

Operators manuals. Click & then Operators Handbooks.

http://www.dbtc.co.uk/index.php?module=zWebstore&func=view&ot=product

Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Author Message
davem.nsOffline
Post subject: 1200 hydraulic problem  PostPosted: 14.01.2012, 23:05



Joined: 28.12.2011
Digby, Nova Scotia, Canada
Posts: 1
Location: Digby, Nova Scotia, Canada
Status: Offline
I'm a newby here and was looking for some advice. I have 1200 David Brown selectomatic> I just bought the tractor a few weeks ago. The tractor has front end loader, works fine. The trans fluid I changed with new filter. Cleaned two valves on top of rear axle. Filter was dirty and one valve was pluged (outside one) The rear draw bar will work up and down at one speed, adjustment of speed makes no difference. When the draw bar gets to height it hiccups. When i stand or put weight on it, it lowers. It will not lift me when standing on the draw bar, when i get off it raises, when it stops it hiccups. I also notice a noise, like a click, like something is not in gauging. When the draw bar is in the up position I can push the draw bar to the ground. No I am not a heavy weight and I'm not the Hulk.
If someone can help me out I would really appreciate it, thanks
 
 View user's profile Send private message  
Reply with quote Back to top
DB770.DB880Offline
Post subject: RE: 1200 hydraulic problem  PostPosted: 15.01.2012, 13:44



Joined: 15.01.2008
N.B. Canada
Posts: 555
Location: N.B. Canada
Status: Offline
What position is the 3-Way-Valve in when you are using the 3-P-H? (3-Way-Valve is the one down by your left heel) it should be in the third positon from the Fended, move the selector to TCU when checking out the Hyd's, in TCU (External) you should have Lift, Hold, Lower & TCU, if it's working OK in TCU position and not in Hight or Depth then it's just adjustment, i sent you a PM with my phone #,
 
 View user's profile Send private message  
Reply with quote Back to top
cambs1594Offline
Post subject: RE: 1200 hydraulic problem  PostPosted: 15.01.2012, 17:25



Joined: 01.06.2011
cambridgeshire
Posts: 1840
Location: cambridgeshire
Status: Offline
id say the seals have failed on the main lift cylinder, this would explain all the symptoms you have listed

_________________
990 selectamatic
1390/gd90 loader
1494
1594 comm edition
 
 View user's profile Send private message Send e-mail  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 11 Hours
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Powered by Zafenio