Forums

LAST FORUM POSTS
goto Post996 4wd(45)
 by mudder394
 on 18. Apr at 12
goto PostRE: 1594 Hydraulic p...(2)
 by ada5583
 on 18. Apr at 12
goto PostDB 996 Back Tyre(6)
 by 1194case
 on 18. Apr at 12
goto PostRE: 1490 Clutch stuc...(21)
 by bedwards1966
 on 18. Apr at 12
goto PostRE: 1594 Hydraulic p...(2)
 by Powerrabbit
 on 18. Apr at 12

[Access Forum]

Operators manuals. Click & then Operators Handbooks.

http://www.dbtc.co.uk/index.php?module=zWebstore&func=view&ot=product

Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Author Message
rich880Offline
Post subject: 1594 lift not working after a few hours  PostPosted: 10.06.2013, 19:55



Joined: 10.06.2013
France
Posts: 10
Location: France
Status: Offline
hi , i've recently bought a 1594, which after a few hours work with the plough gets slower and slower lifting until it wouldn't lift at all ,and the back axle gets too hot to hold your hand on it. but it will turn the plough over on tick over with no probs. (the tractor has a new tandem pump ) could it be that the plough i'm using is a bit on the heavy side for the tractor (it's missing it's twin assister rams ) or is it some other fault ?
thanks rich


Last edited by rich880 on 11.06.2013, 08:12; edited 1 time in total
 
 View user's profile Send private message  
Reply with quote Back to top
erkkiOffline
Post subject: RE: 1594 lift not working after a few hours  PostPosted: 11.06.2013, 05:32



Joined: 09.04.2006
North Finland
Posts: 1601
Location: North Finland
Status: Offline
Hmmmm. Very hot oil can be the explanation to lost power but I wonder why the oil gets hot.
In heavy pulling there will become heat from internal friction of the gearbox but if the box temperature exceeds what you can tolerate by bare hand, maybe its good idea to check that the hydraulic system is not full time pressurized against overpressure valve.

RGDS erkki
 
 View user's profile Send private message  
Reply with quote Back to top
rich880Offline
Post subject: RE: 1594 lift not working after a few hours  PostPosted: 11.06.2013, 08:10



Joined: 10.06.2013
France
Posts: 10
Location: France
Status: Offline
hi , thanks for the reply , i forgot to say the arms go up with the lever in the lowering position but go down when you stand on them and that the arms judder and over correct them selves very violently unless the the draft lever is near the front of its slot ,and when it gets hot and wouldn't lift it gets very noisy around the valve chest area
thanks rich
 
 View user's profile Send private message  
Reply with quote Back to top
885macOffline
Post subject: RE: 1594 lift not working after a few hours  PostPosted: 12.06.2013, 20:42



Joined: 18.02.2012
Belfast
Posts: 99
Location: Belfast
Status: Offline
Hello all going to add my problems too in case its similar causes. Firstly when the lift arms are full up and I put brakes on is seems to be pulsing in the pedals when I lower arms slighlty it stops!! Also noticed when baling the other day the pto was more than hand hot! Any ideas??
 
 View user's profile Send private message  
Reply with quote Back to top
885macOffline
Post subject: RE: 1594 lift not working after a few hours  PostPosted: 20.06.2013, 14:23



Joined: 18.02.2012
Belfast
Posts: 99
Location: Belfast
Status: Offline
Is there an oil cooler for the oil in the backend?
 
 View user's profile Send private message  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 11 Hours
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Powered by Zafenio